ESXi 4.1 and PS/2 keyboards

I've recently upgraded/migrated our ESX 4.0 servers to ESXi 4.1, as VMware stated that 4.1 will be the last ESX release and recommended the migration to ESXi.

The migration itself didn't pose any problem as there isn't a migration process per se. You just have to migrate your VMs to another host and install the ESXi hypervisor. All went well until I had to press 'Enter' to install. It just didn't work.

It seems that ESXi 4.1 has a problem with (some?) PS/2 keyboards on (some?) servers. I tried the install CD on 3 different models of Fujitsu-Siemens servers and it didn't work on eighter one of them.
The solution was to use an USB keyboard for the install. It still remains an inconvenience as we have all the 30-40 servers (still, only 3 ESX :) connected through KVMs with PS/2 keyboard connectors.

LATER EDIT:

Thanks to Valentin Hristev (see comment below), there is solution to use the PS/2 keyboard:
When you boot your ESXi 4.1 and see blue screen fast press TAB to edit boot options then edit with "acpi=off" it should look like this:

mboot.c32 vmkboot.gz acpi=off --- vmkernel.gz --- sys.vgz --- cim.vgz --- ienviron.vgz --- install.vgz


Dell MD3000i slow write speed - cache deactivated

(credits for this article to vmtoday.com, for an article about a similar IBM array, with slightly different commands)

I stumbled across a problem earlier this year with PowerVault MD3000i SAN array and didn't find a specific resolution for this storage, so I though I write about it here so you can solve it easier.

When you buy the MD3000i with only one controller, it deactivates the write cache, becouse the write mirroring feature is enabled (which requires two controllers). The result is that the writing speed is very low and the latency is high.

To activate the cache you need to use the CLI tool provided with the Modular Disk Storage Manager software, which you can find here: C:\Program Files\Dell\MD Storage Manager\client\SMcli.exe. You can first locate the virtual disks that have the cache suspended (Array0 is the name of my array, you should change it to whatever yours is named)

smcli.exe -n Array0 -c "show allVirtualDisks;"
... Write cache: Enabled (currently suspended)
... Write cache with mirroring: Enabled

To disable the mirroring feature and enable caching:

smcli.exe -n Array0 -c "set allVirtualDisks mirrorEnabled=false;"
smcli.exe -n Array0 -c "set allVirtualDisks writeCacheEnabled=true;"

Later edit:

smcli.exe -n Array0 -c "set allVirtualDisks cacheWithoutBatteryEnabled=true;"

vSphere - Sluggish mouse on Windows 7 and 2008 Server

I had this issue after installing Windows 2008 R2 on VMWare ESX 4.0 (208111). Even though I installed VMWare tools, the mouse was still acting as if the driver wasn't installed - the mouse is jumpy and is not leaving the console after the "real" mouse is exiting the screen.

It seems that VMWare is aware of this issue and will solve it eventually.

Anyway, this is the quick fix:
  • install VMWare Tools in your machine, reboot;
  • VMWare tools has created the folder: C:\Program Files\Common Files\VMware\Drivers\wddm_video;
  • go to Device Manager, to your video adapter and select "Update driver";
  • when asked for the files, browse to the folder above;
  • reboot;
  • problem fixed!
LE: after every VMWare tools update you need to redo these steps.

    Integrating VMWare ESX into your enterprise network with VLANs, trunking, load balancing

    VMWare ESX 3 and VSphere can fit nicely into your enterprise network, adding unprecedented flexibility and functionality; after you've got the taste you'll be hooked on it. Virtual machines can be moved from one VLAN to another with a few cliks.
    First of all, about load balancing... If you have VSphere installed on an enterprise server then you most likely have 2 gigabit network interfaces at your disposal. These NICs can be "teamed" for load balancing and failover purposes. As you will see further in the article, load balancing will work even if the swith doesn't support load balancing, but it will only work for outgoing traffic. To make the most of load balancing you need to use a switch that supports etherchannel; in this way the switch will send traffic to the server on both ports, based on the load balancing scheme we configure. In this example we'll be using the Cisco Catalyst 2960G switch.
    You can find network configuration of the ESX host on tab Configuration - section Hardware - Networking. You'll probably use vSwitch0 to configure your network interfaces and VLANs. At first you'll have only one NIC added to the vSwitch. You need to add the second interface. Go to the properties of vSwitch0, go to Network Adapters and click on Add to add the other interface; this is how vSwtich0 will look like aftewards:




    Go back to Ports on the tab above to configure load balancing. Edit the vSwitch device and go to NIC teaming. In this example we'll be using load balancing based on IP hash. So configure "Route based on ip hash" in the Load balancing section:




    Next step is to configure the switch. In this first phase we assume that you're running the ESX server in access mode (no VLAN trunking), in VLAN10. Identify the ports in the switch that belong to the ESX server and configure the port channel (we'll assume that you don't have any other port channels configured):

    sw(config)#interface range g0/1 - 2
    sw(config-if-range)#switchport mode access
    sw(config-if-range)#switchport access vlan 10
    sw(config-if-range)#channel-group 1 mode on

    Now the communication with the ESX should work; if not, take the ports out of the port channel and fix your configuration.
    If everything is ok now, we can prepare the ESX server for VLAN trunking. We need to put the Service Console interface on the desired VLAN - for example, VLAN 10: go to the properties of vSwitch0 and edit the Service Console; click on "Continue modifying the connection" to pass that warning; type your VLAN ID in the next window:




    At this point you will lose connectivity to the ESX server. To restore it, configure VLAN trunking on the switch:

    sw(config)#interface port-channel 1
    sw(config-if)#switchport mode trunk
    sw(config)#interface range g0/1 - 2
    sw(config-if-range)#switchport mode trunk

    If you have VMotion or iSCSI or NFS volumes configured, then you need to configure also the VMkernel VLAN, in the same way you configured the Service Console.

    In case something goes wrong and you need to troubleshoot you configuration:

    - you can check the etherchannel load balancing on the switch:

    sw#show etherchannel load-balance
    EtherChannel Load-Balancing Configuration:
    src-dst-ip
    EtherChannel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: Source XOR Destination MAC addressIPv4: Source XOR Destination IP address
    IPv6: Source XOR Destination IP address

    - you can log in to the ESX server console and, for example, configure the VLAN ID of the service console:

    [root@server root]# esxcfg-vswitch -v -p “Service Console” vSwitch0

    To add a VLAN for your virtual machines go to vSwtich0 properties and "Add...", choose connection type "Virtual machine", type your VLAN name for easy identification and the VLAN ID:



    Then, moving the virtual machines from one VLAN to another is simple: edit settings on the desired virtual machine and select the network adapter; on the network label drop-down list you will get the VLAN you configured.

    Follow by Email

    Sponsored Links

    Labels